Problem with the "Pushover Analysis of 2-Story Moment Frame Example"

Forum for OpenSees users to post questions, comments, etc. on the use of the OpenSees interpreter, OpenSees.exe

Moderators: silvia, selimgunay, Moderators

Post Reply
sarahazar
Posts: 2
Joined: Thu Jul 05, 2018 3:51 am
Location: AUB

Problem with the "Pushover Analysis of 2-Story Moment Frame Example"

Post by sarahazar » Thu Mar 11, 2021 6:23 am

Hello!
I was trying to run the example posted by Dr. Laura Eads (Pushover Analysis of 2-Story Moment Frame). I am getting this error when I run it on OpenSees v.3.2.1 : ProfileSPDLinDirectSolver::solve() - aii < 0 (i, aii): (9, 0)
How can I remove this error? Do I need to use the older version of OpenSees for it to run without any error?

Thank you!

selimgunay
Posts: 888
Joined: Mon Sep 09, 2013 8:50 pm
Location: University of California, Berkeley

Re: Problem with the "Pushover Analysis of 2-Story Moment Frame Example"

Post by selimgunay » Sat Mar 13, 2021 7:50 am

You can try a different linear system of equations solver and see if it works

sarahazar
Posts: 2
Joined: Thu Jul 05, 2018 3:51 am
Location: AUB

Re: Problem with the "Pushover Analysis of 2-Story Moment Frame Example"

Post by sarahazar » Sun Mar 14, 2021 12:32 am

Thank you for your reply.
The error occurs in the Modal Analysis when using the "eigen" command.
Apparently, it is something related to the stiffness of the leaning column
The error disappeared when I changed the zero-stiffness elastic rotational spring of the leaning column to 10^-7 instead of 10^-9

selimgunay
Posts: 888
Joined: Mon Sep 09, 2013 8:50 pm
Location: University of California, Berkeley

Re: Problem with the "Pushover Analysis of 2-Story Moment Frame Example"

Post by selimgunay » Sun Mar 14, 2021 9:45 am

Okay, sounds good. Now I remember other people experienced this problem also and that was the solution

Post Reply