Problem with Add a New Material?

For developers writing C++, Fortran, Java, code who have questions or comments to make.

Moderators: silvia, selimgunay, Moderators

Post Reply
Willsm
Posts: 2
Joined: Sat Mar 12, 2016 8:50 pm
Location: Southeast University

Problem with Add a New Material?

Post by Willsm » Sat Oct 15, 2016 6:15 pm

I compiled New Materia.dll file successfully but failed to run. When I run the model, software prompted "OpenSees.exe has stopped working." I check my .tcl codes and found software went wrong in creating material, however, there is no warning "can't create new material".

I have no idea about this, Anyone can solve this problem? or thoughts?
Thanks

fmk
Site Admin
Posts: 5866
Joined: Fri Jun 11, 2004 2:33 pm
Location: UC Berkeley
Contact:

Re: Problem with Add a New Material?

Post by fmk » Wed Oct 19, 2016 9:26 am

are you using the svn version that corresponds with the release version that the exe spits out when it starts.

Willsm
Posts: 2
Joined: Sat Mar 12, 2016 8:50 pm
Location: Southeast University

Re: Problem with Add a New Material?

Post by Willsm » Thu Oct 20, 2016 5:46 am

Thank you very much!
I check the svn version and find it doesn't corresponds with the release version. After updating to the last version, the problem is solved and program runs well.

tuanrlc
Posts: 9
Joined: Fri Jul 22, 2016 8:13 pm
Location: Kunsan National University, South Korea

Re: Problem with Add a New Material?

Post by tuanrlc » Tue Nov 01, 2016 6:26 am

Hi Willsm!
Can you show me the version SVN which you had used?
Thanks!

fmk
Site Admin
Posts: 5866
Joined: Fri Jun 11, 2004 2:33 pm
Location: UC Berkeley
Contact:

Re: Problem with Add a New Material?

Post by fmk » Fri Nov 04, 2016 5:34 am

when you start OpenSees you will see a revision number in the text that is output .. you need to use that revision number and not the one he used as that will not work for you unless you are using the same .exe

tuanrlc
Posts: 9
Joined: Fri Jul 22, 2016 8:13 pm
Location: Kunsan National University, South Korea

Re: Problem with Add a New Material?

Post by tuanrlc » Mon Nov 21, 2016 11:36 pm

Many thanks, fmk

Post Reply