Compilimg Error (the latest svn repository)

For developers writing C++, Fortran, Java, code who have questions or comments to make.

Moderators: silvia, selimgunay, Moderators

Post Reply
sb1966
Posts: 152
Joined: Wed Jul 23, 2008 8:08 am
Location: NERIST, INDIA
Contact:

Compilimg Error (the latest svn repository)

Post by sb1966 » Thu May 26, 2016 8:41 am

Dear fmk,

I am happy to inform that finally I have been able to check out the svn repository today. Now my SRC is up to date. :D

However, while making, I have got the following error: ( in OpenSees/SRC)
======================================================================
ConcretewBeta.cpp:146:27: error: ‘MAT_TAG_ConcwBeta’ was not declared in this scope
: UniaxialMaterial(tag, MAT_TAG_ConcwBeta),
^
ConcretewBeta.cpp: In constructor ‘ConcretewBeta::ConcretewBeta()’:
ConcretewBeta.cpp:200:25: error: ‘MAT_TAG_ConcwBeta’ was not declared in this scope
: UniaxialMaterial(0, MAT_TAG_ConcwBeta),
^
make[2]: *** [ConcretewBeta.o] Error 1
make[2]: Leaving directory `/home/sukumar/OpenSees/SRC/material/uniaxial'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/sukumar/OpenSees/SRC/material'
make: *** [all] Error 2
sukumar@sukumar-HP-Elite-7100-Microtower-PC:~/OpenSees/SRC$
=====================================================================

would you kindly advise me how to resolve the above? I may add that [b] I have not done any change in my makefile.def. The same file was used to compile my earlier OpenSees bin. My OS is Ubuntu 14.04, 64 bit.[/b]

Thanks a lot.

With warm regards
----------------------------------
With Regards,
sb1966

sb1966
Posts: 152
Joined: Wed Jul 23, 2008 8:08 am
Location: NERIST, INDIA
Contact:

Re: [SOLVED] Compilimg Error (the latest svn repository)

Post by sb1966 » Sun May 29, 2016 5:31 am

Dear fmk and all,

1. I have got the new OpenSees (2.5.0) compiled in Ubuntu 14.04 LTS, 64 bit :D
2. This was possible only after complete removal of earlier version and complete new download. Possibly there was some conflict with different svn downloads at different times.
3. Also I had to do corresponding change in the Mkaefile.def to use SuperLU_5.1.1

4. I am posting it, thinking that it might be helpful to some one.

5. I have only one (possibly trivial) query: While invoking OpenSees it says version 2.5.0 (32 bit) although my system is 64 bit. Kindly reply if it is important

Regards and thanks for your generous support.
----------------------------------
With Regards,
sb1966

fmk
Site Admin
Posts: 5866
Joined: Fri Jun 11, 2004 2:33 pm
Location: UC Berkeley
Contact:

Re: Compilimg Error (the latest svn repository)

Post by fmk » Wed Jun 01, 2016 10:13 am

5. the 32 bit is coming from OPS_Globals.h in OpenSees/SRC .. the message is coming from tclMain.cpp in /OpenSees/SRC/tcl

Post Reply