Problem after sp load pattern

Forum for OpenSees users to post questions, comments, etc. on the use of the OpenSees interpreter, OpenSees.exe

Moderators: silvia, selimgunay, Moderators

Post Reply
xantis85
Posts: 16
Joined: Tue Sep 06, 2011 7:54 am
Location: FedericoII

Problem after sp load pattern

Post by xantis85 » Fri Sep 25, 2020 2:02 pm

Hi,
I've a problem when trying to perform eigen analysis after a load pattern that imposes a known displacement path adopting sp command:

pattern Plain 3 "Series -dt $dt -filePath $DispHistory1 -factor 1.0" {
sp 1002 1 1.0
sp 1003 1 1.0
}


where DispHistory1 is a txt file containing a displacement time history.

In particular, when I try to perform eigen analysis right before this command i got T1=0.52s, T2=0.27s. Just after few steps of the DispHistory1 (e.g. 10 steps), the eigen analysis gives me T1=1.1835448750578083e-5, T2=1.1827034004973583e-5. I think that is something related to sp command that generates a single-point constraint. It should be removed by applying the command:

remove sp 1002 1
remove sp 1003 1

however nothing changes.

Further, after this displacement time history I'm also trying to perform a pushover analysis by applying loads with a displacement control procedure. In this case, i got the following message:

WARNING PlainHandler::handle() - non-homogeneos constraint for node 1002 homo assumed
WARNING PlainHandler::handle() - non-homogeneos constraint for node 1003 homo assumed.
DisplacementControl::newStep() - dof is fixed or constrained (or domainChanged has not been called!)

I've also tried to adopt Lagrange and Penalty as CONSTRAINTS handler as suggested in older posts, but nothing changes. If instead of using sp command I use load command, everygthing works, so It should be something connected with the use of sp.
Could someone give me some tip?

Thank you very much in advance

mhscott
Posts: 586
Joined: Tue Jul 06, 2004 3:38 pm
Location: Corvallis, Oregon USA
Contact:

Re: Problem after sp load pattern

Post by mhscott » Sat Sep 26, 2020 8:22 am

You can't remove sp constraints by node tag and dof. I know, seems like you should be able to, but you can't.

Try removing the load pattern instead

remove loadPattern 3

xantis85
Posts: 16
Joined: Tue Sep 06, 2011 7:54 am
Location: FedericoII

Re: Problem after sp load pattern

Post by xantis85 » Sat Sep 26, 2020 9:37 am

Dear Professor Scott,
thank you very much for your quick reply. I tried to remove the loadPattern 3, but the problem still arise.
I've solved by using Multiple support command instead of pattern Plain.

set patternTag 3;
pattern MultipleSupport $patternTag {
timeSeries Path 100 -dt 0.005 -filePath "DispHistory1_ULS.txt"
timeSeries Path 200 -dt 0.005 -filePath "DispHistory2_ULS.txt"

groundMotion 101 Plain -disp 100 -fact 1.0
groundMotion 201 Plain -disp 200 -fact 1.0

imposedMotion 1002 1 101
imposedMotion 1003 1 101
imposedMotion 1004 1 201
imposedMotion 1005 1 201
}

This way the command:

remove loadPatter 3

works fine and I've no more problems during the following eigen analysis.

Thank you very much

Marco

Post Reply