CuSP doesn't work

Forum for OpenSees users to post questions, comments, etc. on the use of the OpenSees interpreter, OpenSees.exe

Moderators: silvia, selimgunay, Moderators

Post Reply
Posts: 4
Joined: Wed Dec 19, 2018 2:01 am
Location: Korea University

CuSP doesn't work

Post by gifariz » Sat Jun 13, 2020 2:16 am

Hi, I have problem with GPU-based CuSP system solver. I have tried to follow installation procedures, but my OpenSees can't do any analysis with system CusSP (the OpenSees.exe just closes automatically with empty recorder output). I have searched and read previous posts about this but none of them helps. Here what I have tried:
1. Install CUDA 5.5 (my OS is Windows 7 and my graphic card is Nvidia GTX 750, which I believe support GPU utilization)
2. Download both cusplibrary-0.5.1 and cusplibrary-develop and extract it to where my OpenSees.exe executable file is located.
3. Download CuSPSolver.dll (x64) from openseeswiki and copy it to both .exe and script directory.
4. Add the .exe and .dll directory to PATH environment variable.
5. Installed latest graphic card driver (version May 2020)

Can anyone please help? Is there anything I missed? Maybe cusplibrary should be installed somehow, not just copy? Or perhaps OpenSees doesn't support CUDA version higher than 5.5?

Post Reply