Error while building OpenSees source code by Visual Studio

Forum for OpenSees users to post questions, comments, etc. on the use of the OpenSees interpreter, OpenSees.exe

Moderators: silvia, selimgunay, Moderators

Post Reply
kesavapraba
Posts: 46
Joined: Mon Jan 22, 2018 1:38 am

Error while building OpenSees source code by Visual Studio

Post by kesavapraba » Mon Apr 16, 2018 8:46 pm

Dear Friends
I am getting the following error when I build the solution (OpenSees.sln for WIN64) of the source code that I downloaded yesterday using TortoiseSVN.

Error: LINK1181 cannot open input file 'tcl86t.lib'

The release version is 6709 and I am using VisualStudio2017. Can anyone help me out to identify what goes wrong and fix it?

fmk
Site Admin
Posts: 5866
Joined: Fri Jun 11, 2004 2:33 pm
Location: UC Berkeley
Contact:

Re: Error while building OpenSees source code by Visual Stud

Post by fmk » Mon Apr 16, 2018 9:38 pm

did you install tcl .. if so probably in wrong place .. find where tcl lib is and then and then edit the project setting to use that file.

kesavapraba
Posts: 46
Joined: Mon Jan 22, 2018 1:38 am

Re: Error while building OpenSees source code by Visual Stud

Post by kesavapraba » Tue Apr 17, 2018 12:37 am

Dear Frank
Thanks for your quick and prompt reply. Yes, I have installed Tcl in the correct location as you instructed. I could not find tcl86t.dll anywhere in Tcl folder. Does the very recent source that I downloaded yesterday requires me to install Tcl version 8.6? Is that error due to the conflict in Tcl version? Because I had Tcl version 8.5 installed when I build the source code.

fmk
Site Admin
Posts: 5866
Joined: Fri Jun 11, 2004 2:33 pm
Location: UC Berkeley
Contact:

Re: Error while building OpenSees source code by Visual Stud

Post by fmk » Wed Apr 18, 2018 3:55 pm

no .. it is looking for a lib it cannnot find .. look to see in the opensees project settings where tcl86t.lib is being set and try changing to tcl86.lib or whatever the lib you have is.

CMiculas
Posts: 27
Joined: Wed Oct 25, 2017 6:23 am
Location: University of Coimbra

Re: Error while building OpenSees source code by Visual Stud

Post by CMiculas » Tue May 15, 2018 5:04 am

kesavapraba wrote:
> Dear Frank
> Thanks for your quick and prompt reply. Yes, I have installed Tcl in the
> correct location as you instructed. I could not find tcl86t.dll anywhere
> in Tcl folder. Does the very recent source that I downloaded yesterday
> requires me to install Tcl version 8.6? Is that error due to the conflict
> in Tcl version? Because I had Tcl version 8.5 installed when I build the
> source code.

I am facing the same problem. Did you manage to solve it?

kesavapraba
Posts: 46
Joined: Mon Jan 22, 2018 1:38 am

Re: Error while building OpenSees source code by Visual Stud

Post by kesavapraba » Tue May 15, 2018 5:17 am

No. I did not solve it. It error says tcl86.lib should be referred. But I do not find any lib file in the same name. And moreover I installed 8. 6 version of Tcl and found tcl86.lib file...Then after I ran the file, but it resulted with lot of other errors. I think Dr. Frank and his team can help us.

Post Reply