Get_Rendering modules not working?

Forum for asking and answering questions related to use of the OpenSeesPy module

Moderators: silvia, selimgunay, Moderators

Post Reply
kavian
Posts: 1
Joined: Tue Aug 13, 2013 6:11 pm
Location: Universidad de Chile

Get_Rendering modules not working?

Post by kavian » Wed Jul 29, 2020 8:12 pm

Hello everyone,

I'm testing OpenSeesPy (new to Python btw, but I have time), and I was checking the plotting features and there are two that didn't work, I hope its just me.

I installed Anaconda, and under Spyder I installed Openseespy and updated it to the version 3.2.2. Then on my -simple model script I start with

Code: Select all

from openseespy.opensees import *
from openseespy.postprocessing.Get_Rendering import *
But then, when I try to use "createODB()" or "ani =animate_deformedshape()" functions I just get the following error:

NameError: name 'createODB' is not defined

I reviewed the Get_Rendering script installed in my disk and it doesn't include the functions createODB() or animate_deformedshape(). But they are included in the code of GitHub ( Check here).

How can I properly install the latest version of Get_Rendering to have these functions working, without modifying it locally "by hand"?

Thank you and great work!!
Nestor

cslotboom
Posts: 6
Joined: Sun Sep 09, 2018 8:09 pm
Location: UBC

Re: Get_Rendering modules not working?

Post by cslotboom » Sat Aug 08, 2020 3:47 pm

Hey,

Maybe a little late, but the pip version is currently updating.
The get rendering is updated on github but not pip.

If you manually install the files everything should work!
Hopefully the pip version will be updated soon.

Cheers,
C.

Post Reply