industrialFrame.tcl not working under OpenSees 2.4.6

A place to ask questions on how to use OpenSees to perform Finite Element Reliability Analysis

Moderators: silvia, selimgunay, mhscott, Moderators

Post Reply
rafal
Posts: 50
Joined: Sun Feb 22, 2015 5:58 am

industrialFrame.tcl not working under OpenSees 2.4.6

Post by rafal » Mon Jul 13, 2015 5:12 am

Hello,
I would like to inform you that
industrialFrame.tcl found in trunk/EXAMPLES/Reliability directory does not work under OpenSees 2.4.6 (Windows build). While version 2.4.5 works correctly on this example.
After running the script I get:
-------------------------------------------------------------------------------------
OpenSees -- Open System For Earthquake Engineering Simulation
Pacific Earthquake Engineering Research Center -- 2.4.6 (rev 6016)

(c) Copyright 1999-2013 The Regents of the University of California
All Rights Reserved
(Copyright and Disclaimer @ http://www.berkeley.edu/OpenSees/copyright.html)


WARNING analysis Static - no ConstraintHandler yet specified,
PlainHandler default will be used
WARNING analysis Static - no Numberer specified,
RCM default will be used

Frame analysis using mean values of random variables

Basic forces of element 1: -1046.63178805 251.28726947 252.57272516
Basic forces of element 2: -1104.76178349 244.18479811 232.30828211
FORM Analysis is running ...
Limit-state function number: 1
-------------------------------------------------------------------------------------------
then OpenSees program crashes.

rafal
Posts: 50
Joined: Sun Feb 22, 2015 5:58 am

Re: industrialFrame.tcl not working under OpenSees 2.4.6

Post by rafal » Sat Jul 18, 2015 9:32 pm

Now under Linux the additional information is "Segmentation fault" as shown below:

OpenSees -- Open System For Earthquake Engineering Simulation
Pacific Earthquake Engineering Research Center -- 2.4.6 (rev 6022)

(c) Copyright 1999-2013 The Regents of the University of California
All Rights Reserved
(Copyright and Disclaimer @ http://www.berkeley.edu/OpenSees/copyright.html)


WARNING analysis Static - no ConstraintHandler yet specified,
PlainHandler default will be used
WARNING analysis Static - no Numberer specified,
RCM default will be used

Frame analysis using mean values of random variables

Basic forces of element 1: -1046.63178805 251.28726947 252.57272516
Basic forces of element 2: -1104.76178349 244.18479811 232.30828211
a
FORM Analysis is running ...
Limit-state function number: 1
Segmentation fault

rafal
Posts: 50
Joined: Sun Feb 22, 2015 5:58 am

Re: industrialFrame.tcl not working under OpenSees 2.4.6

Post by rafal » Sun Jul 19, 2015 11:17 am

I spent some time to find out what svn revision is responsible for this segmentation fault in industrialFrame.tcl example. And using bisecting method this is what I found:
1) last revision which works is -r5908,
2) revision r5909 does not build correctly; some errors during 'make'
3) revision r5910 builds OK and gives the segmentation fault

rafal
Posts: 50
Joined: Sun Feb 22, 2015 5:58 am

Re: industrialFrame.tcl not working under OpenSees 2.4.6

Post by rafal » Thu Aug 20, 2015 5:44 am

Dear Michael and Frank

I tried to find out what is the problem with the industrialFrame.tcl, so I run it through gdb debugger under linux. Below is the output. Note that I also found that in other files when computGradient function is activated the segmentation fault occurs as well. So maybe the problem is with "computeGradient" code?

$ gdb --args OpenSees6067debug rel_industrialFrame.tcl

GNU gdb (Debian 7.9.1-1) 7.9.1
Copyright (C) 2015 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from OpenSees6067debug...done.


(gdb) run
Starting program: /home/sewi/bin/OpenSees6067debug rel_industrialFrame.tcl
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".


OpenSees -- Open System For Earthquake Engineering Simulation
Pacific Earthquake Engineering Research Center -- 2.4.6 (rev 6067)

(c) Copyright 1999-2013 The Regents of the University of California
All Rights Reserved
(Copyright and Disclaimer @ http://www.berkeley.edu/OpenSees/copyright.html)


[New Thread 0x7ffff6239700 (LWP 29386)]
WARNING analysis Static - no ConstraintHandler yet specified,
PlainHandler default will be used
WARNING analysis Static - no Numberer specified,
RCM default will be used

Frame analysis using mean values of random variables

Basic forces of element 1: -1046.63178805 251.28726947 252.57272516
Basic forces of element 2: -1104.76178349 244.18479811 232.30828211
a
FORM Analysis is running ...
Limit-state function number: 1

Program received signal SIGSEGV, Segmentation fault.
0x000000000131a316 in SensitivityAlgorithm::computeSensitivities (this=0x222bfe0) at SensitivityAlgorithm.cpp:107
107 theSensitivityIntegrator->formIndependentSensitivityRHS();
(gdb) bt full
#0 0x000000000131a316 in SensitivityAlgorithm::computeSensitivities (this=0x222bfe0) at SensitivityAlgorithm.cpp:107
theSOE = 0x222ad00
theIncInt = 0x223d3c0
paramIter = @0x222ad00: {_vptr.ParameterIter = 0x15c9b50 <vtable for UmfpackGenLinSOE+16>}
theParam = 0x347ae147b
numGrads = 0
#1 0x0000000000fd01bb in StaticAnalysis::analyze (this=0x222bf70, numSteps=100) at StaticAnalysis.cpp:201
stamp = 1
i = 0
result = 3
the_Domain = 0x19657a0 <theDomain>
#2 0x0000000000616c1d in analyzeModel (clientData=0x0, interp=0x21817e0, argc=2, argv=0x2186090) at commands.cpp:1668
numIncr = 100
result = 0
#3 0x00007ffff75bd534 in TclInvokeStringCommand () from /usr/lib/x86_64-linux-gnu/libtcl8.5.so
No symbol table info available.
#4 0x00007ffff75bed59 in ?? () from /usr/lib/x86_64-linux-gnu/libtcl8.5.so
No symbol table info available.
#5 0x00007ffff75bfa2b in ?? () from /usr/lib/x86_64-linux-gnu/libtcl8.5.so
No symbol table info available.
#6 0x00007ffff75bf373 in Tcl_EvalEx () from /usr/lib/x86_64-linux-gnu/libtcl8.5.so
No symbol table info available.
#7 0x00007ffff75c0535 in Tcl_Eval () from /usr/lib/x86_64-linux-gnu/libtcl8.5.so
No symbol table info available.
#8 0x00000000013d4d55 in TclEvaluator::runAnalysis (this=0x223c9d0) at TclEvaluator.cpp:170
theParam = 0x223d310
nparam = 19
#9 0x0000000001371b15 in SearchWithStepSizeAndStepDirection::findDesignPoint (this=0x2235730) at SearchWithStepSizeAndStepDirection.cpp:248
lsfTag = 32767
theLimitStateFunction = 0x7fffffffd260
lsfExpression = 0x20202031 <error: Cannot access memory at address 0x20202031>
continueStepSize = false
numberOfRandomVariables = 18
result = 0
evaluationInStepSize = 0
gFunctionValue = 1
gFunctionValue_old = 1
stepSize = 1
u_old = {static VECTOR_NOT_VALID_ENTRY = 0, sz = 18, theData = 0x2244530, fromFree = 0}

uNew = {static VECTOR_NOT_VALID_ENTRY = 0, sz = 18, theData = 0x22445d0, fromFree = 0}
#10 0x0000000001336dc6 in FORMAnalysis::analyze (this=0x2241fc0) at FORMAnalysis.cpp:164
xStar = @0x1336753: {static VECTOR_NOT_VALID_ENTRY = 0, sz = -129660088, theData = 0x458b480000012890, fromFree = -2134423304}
uStar = @0x7fffffffd830: {static VECTOR_NOT_VALID_ENTRY = 0, sz = 2, theData = 0x2, fromFree = -10096}
theRV = 0x7fff00000014
relInfo = {_vptr.Information = 0x200000005, theType = 33958752, theInt = 0, theDouble = 6,9533558072800698e-310, theID = 0x11a54ed <CorotCrdTransf2d::compTransfMatrixBasicLocal(Matrix&)+1387>,
theVector = 0x2062b60 <CorotCrdTransf2d::Tbl>, theMatrix = 0x21f0140, theString = 0xbfb8000000000000 <error: Cannot access memory at address 0xbfb8000000000000>}
lsfTag = 1
lastSearchDirection = @0x7fff0000005b: <error reading variable>
firstCurvature = 6,9533558073330336e-310
alpha = @0x2241fc0: {static VECTOR_NOT_VALID_ENTRY = 0, sz = 23111408, theData = 0x21cc770, fromFree = 35870512}
gamma = @0x21817e0: {static VECTOR_NOT_VALID_ENTRY = 0, sz = 35133880, theData = 0x0, fromFree = 1}
rvIter = {_vptr.RandomVariableIter = 0x21817e0, myIter = warning: RTTI symbol not found for class 'std::basic_filebuf<char, std::char_traits<char> >'
@0x7fffffffd388}
lsf = 0
stdv = 1,0883961833444823e-316
mean = 6,953348190052619e-310
Go = 0
Glast = 0
beta = 2,6185479229586067e-322
pf1 = 1,7391110733611878e-321
numberOfSteps = 0
numberOfEvaluations = 0
aStdNormRV = {<RandomVariable> = {<ReliabilityDomainComponent> = {<TaggedObject> = {_vptr.TaggedObject = 0x161a620 <vtable for NormalRV+16>, theTag = 1}, theReliabilityDomain = 0x0},
static pi = 3,1415926535897931, static euler = 0,57721566490153287, static zeta3 = 1,2020569031595942, static zeta5 = 1,03692775514337, startValue = 0, rvValue = 0}, mu = 0, sigma = 1}
numRV = 18
theLimitStateFunction = 0x2237f90
delta = {static VECTOR_NOT_VALID_ENTRY = 0, sz = 18, theData = 0x2242100, fromFree = 0}
eta = {static VECTOR_NOT_VALID_ENTRY = 0, sz = 18, theData = 0x22421a0, fromFree = 0}
kappa = {static VECTOR_NOT_VALID_ENTRY = 0, sz = 18, theData = 0x2242240, fromFree = 0}
outputFile = <incomplete type>
#11 0x0000000001327a15 in TclReliabilityModelBuilder_runFORMAnalysis (clientData=0x0, interp=0x21817e0, argc=2, argv=0x2185c60) at TclReliabilityBuilder.cpp:3757
relSensTag = 0
#12 0x00007ffff75bd534 in TclInvokeStringCommand () from /usr/lib/x86_64-linux-gnu/libtcl8.5.so
No symbol table info available.
---Type <return> to continue, or q <return> to quit---
#13 0x00007ffff75bed59 in ?? () from /usr/lib/x86_64-linux-gnu/libtcl8.5.so
No symbol table info available.
#14 0x00007ffff75bfa2b in ?? () from /usr/lib/x86_64-linux-gnu/libtcl8.5.so
No symbol table info available.
#15 0x00007ffff75bf373 in Tcl_EvalEx () from /usr/lib/x86_64-linux-gnu/libtcl8.5.so
No symbol table info available.
#16 0x00007ffff762a152 in Tcl_FSEvalFileEx () from /usr/lib/x86_64-linux-gnu/libtcl8.5.so
No symbol table info available.
#17 0x00007ffff7628b47 in Tcl_EvalFile () from /usr/lib/x86_64-linux-gnu/libtcl8.5.so
No symbol table info available.
#18 0x000000000061448d in g3TclMain (argc=1, argv=0x7fffffffe2b0, appInitProc=0x61497e <Tcl_AppInit(Tcl_Interp*)>, rank=0, np=1) at tclMain.cpp:316
resultPtr = 0x7ffff6988e49 <__cxa_atexit+25>
commandPtr = 0x0
buffer = "0\000\377\377\377\177\000\000\200\335\377\377\377\177\000\000\000\000\000\000\000\000\000\000`3\375\367\377\177\000\000\350T\375\367\377\177\000\000[\253#\367\377\177\000\000x\035\226\366\377\177\000\000\\L\336\367\377\177\000\000\000\000\000\000\001\000\000\000\207\360\226|\000\000\000\000\a\000\000\000\000\000\000\000\v\000\000\000\000\000\000\000\300F\375\367\377\177\000\000\316U\336\367\377\177\000\000\030\337\377\377\377\177\000\000\360\335\377\377\377\177\000\000(M\225\366\377\177\000\000X\034\226\366\377\177\000\000\000\337\377\377\377\177\000\000\302[\362\001\000\000\000\000\360\336\377\377\377\177\000\000\060\336\377\377\377\177\000\000\000\000\000\000\000\000\000\000`3\375\367\377\177\000\000\350T\375\367\377\177\000\000"...
args = 0x21a1330 "0"
code = 0
gotPartial = 256
tty = 1
length = 0
exitCode = 0
inChannel = 0x150219d <__libc_csu_init+77>
outChannel = 0x16a
errChannel = 0x1962510
interp = 0x21817e0
argString = {string = 0x7fffffffdc70 "rel_industrialFrame.tcl", length = 23, spaceAvl = 200,
staticSpace = "rel_industrialFrame.tcl\000&\204\300\214\004\b\000\002\002\016\241\254\032\004f\300\000\300\062\000\300\000P\001 \201\b\204\v ($\000\004 P\000\020X\200\312DB(\000\006\200\020\030B\000 @\200\000\tP\000Q\212@\020\000\\L\336\367\377\177\000\000\300\340\377\377\377\177\000\000\\L\336\367\377\177\000\000\a\000\000\000\000\000\000\000^\226\223\034\000\000\000\000\a\000\000\000\000\000\000\000\v\000\000\000\000\000\000\000\300F\375\367\377\177\000\000\316U\336\367\377\177\000\000(M\225\366\377\177\000\000P\335\377\377\377\177\000\000(M\225\366\377\177\000\000X\020\226\366\377\177\000\000`\336\377\377\377\177\000"}
numParam = 0
one = "1"
zero = "0"
#19 0x0000000000614977 in main (argc=2, argv=0x7fffffffe2a8) at tclAppInit.cpp:137
No locals.

samk
Posts: 5
Joined: Tue Aug 25, 2015 11:52 pm
Contact:

Re: industrialFrame.tcl not working under OpenSees 2.4.6

Post by samk » Tue Sep 15, 2015 3:32 am

It's working fine . Better you lear your cache check it again.

rafal
Posts: 50
Joined: Sun Feb 22, 2015 5:58 am

Re: industrialFrame.tcl not working under OpenSees 2.4.6

Post by rafal » Tue Sep 15, 2015 11:48 am

The thing is, it does not work either on Windows nor Linux OS. What do you mean lear your cache?
What version of OpenSees do you use?
Can anybody else confirm if it works or not? Or am I doing something stupid?

jamesdamon
Posts: 1
Joined: Thu Nov 19, 2015 1:38 am

Re: industrialFrame.tcl not working under OpenSees 2.4.6

Post by jamesdamon » Thu Nov 19, 2015 1:46 am

I really love the quality writing as offered on this post, cheers to the writer.

Post Reply