Search found 22 matches

by rgrayeli
Sat Jul 30, 2011 11:08 am
Forum: Framework
Topic: Unifying Matrix classes !!
Replies: 1
Views: 756

Unifying Matrix classes !!

Dear Developers and Frank, I'm currently writing a new ND material for soil and rock and for that I need new matrix and vector operators and functions. some of them are available at Matrix and some at BJMatrix class and some does not exist. I just want to know, is there anyway to unify these classes...
by rgrayeli
Sat Feb 19, 2011 3:46 pm
Forum: Framework
Topic: Looping over Elements??
Replies: 1
Views: 923

Looping over Elements??

I'm trying to use "ElementIter" class to loop over all specified elements. my question is, what is the best method to distinguish solid (quads), beam as well as zerolength elements.

Thank
by rgrayeli
Sun Jan 16, 2011 5:38 pm
Forum: Framework
Topic: Can not Debug the source code?
Replies: 3
Views: 1485

Re: Can not Debug the source code?

thank you frank I could fix that ...
by rgrayeli
Tue Jan 11, 2011 11:18 am
Forum: Framework
Topic: Can not Debug the source code?
Replies: 3
Views: 1485

Can not Debug the source code?

Hi; I just did implement a new nDMaterial and trying to debug the created code just simply by adding couple of breakpoints. but unfortunately it seems debugger keep jumping over all breakpoints and going to the end of tcl script and the thing is I'm not getting any error at all. would you please let...
by rgrayeli
Sun Nov 14, 2010 12:45 am
Forum: Framework
Topic: how to store the accumulative stress?
Replies: 1
Views: 940

how to store the accumulative stress?

Hi,

how can I store the accumulative stress of elements while creating a new material? I just realized that I can store them by simply using commitstate() but my another question is, how can I restore the saved value after each step or iteration?

thank you in advance;
by rgrayeli
Wed Sep 15, 2010 2:31 pm
Forum: Soil Modelling
Topic: why can't I edit wiki page that I created myself?
Replies: 2
Views: 1231

thanks Frank, but still I get the following message:

"You do not have permission to edit this page, for the following reason:

The action you have requested is limited to users in the group: emailconfirmed."
by rgrayeli
Tue Sep 14, 2010 9:44 pm
Forum: Soil Modelling
Topic: why can't I edit wiki page that I created myself?
Replies: 2
Views: 1231

why can't I edit wiki page that I created myself?

why can't I edit wiki page that I created myself?
by rgrayeli
Tue Mar 23, 2010 11:29 pm
Forum: Framework
Topic: what did happen to Wiki manual?
Replies: 14
Views: 6127

[quote="fmk"]it is not released yet .. i changed it's url ..
[url]
opensees DOT berkeley DOT edu/wiki/index.php
[/url][/quote]

good tanx for heads up.
by rgrayeli
Tue Mar 23, 2010 8:56 am
Forum: Framework
Topic: what did happen to Wiki manual?
Replies: 14
Views: 6127

what did happen to Wiki manual?

what did happen to Wiki manual? it seems all documents have been vanished.
by rgrayeli
Thu Jan 14, 2010 3:30 pm
Forum: Framework
Topic: submitting code for opensees
Replies: 1
Views: 1035

submitting code for opensees

what is the procedure for submitting code into opensees?
by rgrayeli
Mon Jan 04, 2010 12:57 pm
Forum: Framework
Topic: We are collecting OPENSEES User-Requirements Data
Replies: 15
Views: 29415

Silvia;

I think it time for Opensees developer to think about creating a geometry class as a pre-processors instead of using matlab navigator. if you put the "geometry" class in the opensses project I'm sure people like me are willing to participate.
by rgrayeli
Tue Dec 01, 2009 8:36 am
Forum: Framework
Topic: Linking Error
Replies: 6
Views: 2897

aizen; it seems you are missing more than one external library. you just simply can search for current missing function throughout the opensees file and disable this specific function but the think is you may can not use this element for your model so I prefer you wait until these errors get fixed b...
by rgrayeli
Mon Nov 30, 2009 9:00 am
Forum: Framework
Topic: Linking Error
Replies: 6
Views: 2897

Re: link error new CVS OPENSEES FILES

Hi Aizen; I temporarily fixed that problem by simply disabling the lines that calling "TclModelBuilder_addSingleFPBearing" function from outside. you can go to "TclElementCommands.cpp" file and disable these lines as follow: /* else if (strcmp(argv[1],"singleFPBearing") == 0) { int eleArgStart = 1; ...
by rgrayeli
Fri Nov 20, 2009 12:22 pm
Forum: Framework
Topic: Linking Error
Replies: 6
Views: 2897

Linking Error

Again same error message: element.lib(TclElementCommands.obj) : error LNK2019: unresolved external symbol "int __cdecl TclModelBuilder_addSingleFPBearing(void *,struct Tcl_Interp *,int,char const * *,class Domain *,class TclModelBuilder *,int)" (?TclModelBuilder_addSingleFPBearing@@YAHPAXPAUTcl_Inte...
by rgrayeli
Wed Nov 18, 2009 10:13 am
Forum: Framework
Topic: can not step into specific element class while debugging
Replies: 2
Views: 1515

[quote="burnningcat"]My friend, I have no problem in debugging. So maybe you should try to use the Visual studio 2008 team suit and the lastest sorce code of OpenSees.[/quote] thank you for your response. I am using VS2008 express and do not have any problem in debugging. I can debug the main projec...