A problem on MPICH2 on windows 10

This forum is for issues related to parallel processing
and OpenSees using the new interpreters OpenSeesSP and OpenSeesMP

A problem on MPICH2 on windows 10

Postby paysheen » Tue Dec 11, 2018 12:04 am

Hi
I am having one intimidating problem.
I have installed MPICH2 as all the references said and when I hit : mpiexec -validate it shows "SUCCESS", yet when i want to run the test file "mpiexec -n 4 cpi" it actually takes about to run the file which is weird. but after 1 min it works well. Then i tried to run an opensees file "mpiexec -np 4 openseesmp myfile.tcl" and it after 1-2 min it shows nothing and goes to the new command on the console!! (I even noticed that during this 1-2 min of running the mpiexec neither of my CPU or MEMORY is been used! and i looks like the "mpiexec" is not actually working during this 1-2 min)


What makes more desperate is that I have tried the same things on other LAPTOPS and every thing was ok (e.g. test file "mpiexec -n 4 cpi" was instatenous and even the opensees files works well)
this all happens while my hardwares are better than the other laptops!

I guess it is not a matter of opensees it is more basic, mpich is the problem because for even its simple example file it takes about 1 min to run it.

I have tried any could is possible. I have unistall a reinstall the mpich million times an the problem still remain the same!!! :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry:
paysheen
 
Posts: 23
Joined: Wed Feb 22, 2017 4:18 am
Location: Tehran Polytechnique

Re: A problem on MPICH2 on windows 10

Postby kesavapraba » Thu Jan 03, 2019 3:25 am

Hi Paysheen, I am facing the problem of installation of MPICH. Everything goes fine in the installation process up to "mpiexec -validate" and it fails at that step in my case. Could you please help me out installing mpich properly? Thanks a lot
kesavapraba
 
Posts: 45
Joined: Mon Jan 22, 2018 1:38 am

Re: A problem on MPICH2 on windows 10

Postby paysheen » Thu Jan 03, 2019 3:57 am

what is the output when you input "smpd"?
paysheen
 
Posts: 23
Joined: Wed Feb 22, 2017 4:18 am
Location: Tehran Polytechnique

Re: A problem on MPICH2 on windows 10

Postby memus » Tue Jan 08, 2019 1:08 am

Hi,
I am dealing with the same problem.
MPICH2 is correctly installed (mpiexec -validate => SUCCESS) and I am able to run properly the test file "mpiexec -n 4 cpi" but, as described by Paysheen, the command "mpiexec -np 4 openseesSP(or MP) myfile.tcl" does not show anything and goes to a new command on the console.
I would be really grateful for any suggestions you might provide me.
Thank you in advance.
memus
 
Posts: 3
Joined: Mon Jan 07, 2019 11:57 pm

Re: A problem on MPICH2 on windows 10

Postby paysheen » Tue Jan 08, 2019 8:30 am

I could resolve the problem by reinstall tcl tk file and making sure that it is installed via adminstrator
paysheen
 
Posts: 23
Joined: Wed Feb 22, 2017 4:18 am
Location: Tehran Polytechnique

Re: A problem on MPICH2 on windows 10

Postby memus » Tue Jan 08, 2019 8:53 am

Thank you for your response.
Unfortunately, it has not solved the issue in my case.
Anyway, I repeated the installation procedure on another multi-core machine and it works properly.

Actually, I would have another question. I am running a .tcl script in the OpenSeesSP interpreter through the following command
mpiexec -np 10 OpenSeesSP myfile.tcl
and, although the script is well processed by the interpreter, it seems that the analysis is computed 10 times, as many as the number of processors assigned to the job. I am probably missing something.
I really thank you in advance for any suggestions you might provide me.
memus
 
Posts: 3
Joined: Mon Jan 07, 2019 11:57 pm

Re: A problem on MPICH2 on windows 10

Postby memus » Tue Jan 08, 2019 9:07 am

and, with reference to my previous message, I forgot specifying that the script is composed of a sole dynamic analysis of a very large model to be processed in parallel (OpenSeesSP).
memus
 
Posts: 3
Joined: Mon Jan 07, 2019 11:57 pm

Re: A problem on MPICH2 on windows 10

Postby paysheen » Tue Jan 08, 2019 9:52 am

I could not comprehend your problem. Is not there any output?
paysheen
 
Posts: 23
Joined: Wed Feb 22, 2017 4:18 am
Location: Tehran Polytechnique

Re: A problem on MPICH2 on windows 10

Postby alghossoon » Mon Jan 14, 2019 9:37 pm

Guys, I'm facing the same problem, did any of you get the solution ?
alghossoon
 
Posts: 5
Joined: Sun Sep 24, 2017 7:35 am
Location: Purdue University


Return to Parallel Processing

Who is online

Users browsing this forum: No registered users and 1 guest