about PETSc verison

This forum is for issues related to parallel processing
and OpenSees using the new interpreters OpenSeesSP and OpenSeesMP

about PETSc verison

Postby sanat » Wed Oct 14, 2009 7:03 pm

hi fmk,

I would like to know version restrictions for solvers petsc and mumps for the latest stable release of OpenSees i.e. v2.1.0.

I tried to compile OpenSees 2.1.0 with petsc 3.0.0-p8 and could not get success. Is pets2.3 required?

similarly which verison of mumps is suitable? latest one is v4.9
sanat
 
Posts: 10
Joined: Tue Oct 06, 2009 2:44 am

Postby fmk » Tue Oct 20, 2009 11:18 am

the versions of MUMPS i last used was 4.7.3 and PETSC was 2.2 .. i will try and link with more current versions .. my problem as you are discovering is that they keep changing their interfaces (Petsc in particular) and i need to be able to compile on multiple machines, some of which only contain older versions.
fmk
Site Admin
 
Posts: 5860
Joined: Fri Jun 11, 2004 2:33 pm
Location: UC Berkeley

Postby sanat » Tue Oct 20, 2009 11:59 pm

thanks fmk
sanat
 
Posts: 10
Joined: Tue Oct 06, 2009 2:44 am


Return to Parallel Processing

Who is online

Users browsing this forum: No registered users and 1 guest