REINFORCING STEEL MATERIAL UNDER EARTHQUAKE ANALYSIS

If you have a script you think might be useful to others post it
here. Hopefully we will be able to get the most useful of these incorporated in the manuals.

Moderators: silvia, Moderators

REINFORCING STEEL MATERIAL UNDER EARTHQUAKE ANALYSIS

Postby emrekizilarslan » Thu Dec 14, 2017 11:41 am

Hi

I am using Reinforcing Steel material for steel in composite steel wall. Everything works for cyclic and pushover analysis. On the other hand, when i perform incremental dynamic analysis, at higher increments, the code runs and stops WITHOUT an error. I waited up to two days and nothing changed. I checked the cross section to see if there is still steel left as the material accounts for fracture of steel. However, there is still steel to resist more eq loading.

Details about the modelling: 3 story coupled composite wall and only 24 in from base of the walls and 24 in of ends of coupoled beams are dipBeamColumn element and rest is elastic beam column element. here is the properties i am using for "Reinforcing Steel" material:

set lsr 24.0;
uniaxialMaterial ReinforcingSteel $matSteelTag $fy [expr 65.0*$ksi] $Es [expr 0.0333*$Es] [expr 10*$fy/$Es] 0.15 -GABuck $lsr 1.0 0.6 0.5 -CMFatigue 0.3 0.506 0.0 -IsoHard 4.3 -MPCurveParams 0.333 18.0 4.0;


Has anybody faced the same problem? I really appreciate your help!!
emrekizilarslan
 
Posts: 3
Joined: Wed Mar 29, 2017 6:21 am
Location: SUNT at Buffalo

Re: REINFORCING STEEL MATERIAL UNDER EARTHQUAKE ANALYSIS

Postby emrekizilarslan » Tue Dec 19, 2017 1:11 pm

Hi again,

I really appreciate if somebody can answer this question... I am desperate...
emrekizilarslan
 
Posts: 3
Joined: Wed Mar 29, 2017 6:21 am
Location: SUNT at Buffalo

Re: REINFORCING STEEL MATERIAL UNDER EARTHQUAKE ANALYSIS

Postby luschnei » Thu Dec 28, 2017 6:22 am

I am encountering the same problem with my analysis at the moment. Seems like the ReinforcingSteel Material is running into an infinite loop when i check the source code with Visual Studio.

Did you solve the problem?
luschnei
 
Posts: 3
Joined: Wed Oct 12, 2016 12:47 am
Location: Technische Universität Kaiserslautern

Re: REINFORCING STEEL MATERIAL UNDER EARTHQUAKE ANALYSIS

Postby luschnei » Thu Dec 28, 2017 6:28 am

Just searched for other problems with ReinforcingSteel and it seems like fmk doesnt suggest using it .

viewtopic.php?f=2&t=63316&p=106301&hilit=ReinforcingSteel#p106301
luschnei
 
Posts: 3
Joined: Wed Oct 12, 2016 12:47 am
Location: Technische Universität Kaiserslautern

Re: REINFORCING STEEL MATERIAL UNDER EARTHQUAKE ANALYSIS

Postby emrekizilarslan » Fri Dec 29, 2017 1:20 pm

Thanks luschnei,

I also saw that comment. So I tried with one element it worked but when i increase number of elements, it stops without an error again. So i am now trying to make use of all processors in my personal computer via using OpenSeesSP interpreter. I think the material needs more processors to do iterations. but now sure yet if this causes the stop.
emrekizilarslan
 
Posts: 3
Joined: Wed Mar 29, 2017 6:21 am
Location: SUNT at Buffalo

Re: REINFORCING STEEL MATERIAL UNDER EARTHQUAKE ANALYSIS

Postby luschnei » Wed Jan 03, 2018 2:34 am

As mentioned i think the material is running into an infinite loop from what i saw in the source code when debugging with Visual Studio. So more processors shouldn't solve the problem. I changed the material to Steel02 for my model and it is working now.

But keep me posted if you find that more processors are working, i could definitly be wrong too.
luschnei
 
Posts: 3
Joined: Wed Oct 12, 2016 12:47 am
Location: Technische Universität Kaiserslautern

Re: REINFORCING STEEL MATERIAL UNDER EARTHQUAKE ANALYSIS

Postby aleso » Fri Jan 19, 2018 10:46 am

Meeen! That's exactly what I was looking for! well done indeed
Projects I currently work ok:
1 - Mangosteen
2 - Project Psychoteraphy
aleso
 
Posts: 2
Joined: Fri Jan 19, 2018 10:40 am


Return to Useful Scripts.

Who is online

Users browsing this forum: No registered users and 1 guest

cron